Thứ 2, ngày 9 tháng 12 năm 2019

Ác mộng đe dọa nhiều triệu hệ thống máy tính

25/09/2014 20:05 GMT+7
Lỗi "Bash Shell" ảnh hưởng các hệ thống dùng Linux, họ Unix và cả Apple Mac OS X

TTO - Không thể đếm hết website, máy chủ, từ PC đến Mac, bộ định tuyến... bị lỗi mới được khám phá đe dọa. Nguy cơ tương đương lỗi Heartbleed.

Lỗi
Lỗi "Bash Shell" ảnh hưởng các hệ thống dùng Linux, họ Unix và cả Apple Mac OS X - Ảnh: Legendu.net

Lỗi được công bố vào ngày 24-9, nhanh chóng thu hút được sự chú ý của giới an ninh mạng, bảo mật và cả hacker trên toàn thế giới do phạm vi ảnh hưởng rộng lớn và nguy hiểm không kém lỗi "Trái tim rỉ máu" (Heartbleed) đã từng đe dọa Internet trước đây.

Bash là bộ xử lý lệnh của Unix và các HĐH họ Linux. Lỗ hổng bảo mật trong Bash được khám phá bởi Stephane Chazelas, công bố trên SecLists.org ngày 24-9, mã CVE-2014-6271.

Hiểu cơ bản về lỗi, khi gán hàm vào một biến thì các đoạn mã được định nghĩa trong hàm sẽ được thực thi, qua đó mở rộng cơ hội cho các cuộc tấn công kiểu code-injection (chèn mã). Điểm yếu này có thể khai thác từ xa nếu như mã có thể được gán vào một biến môi trường thông qua giao tiếp mạng.

Lỗi đặt các máy chủ web Apache vào tình trạng nguy hiểm, mang nguy cơ bị tin tặc tấn công, chạy các câu lệnh điều khiển từ xa. OpenSSH và một số DHCP-client cũng bị ảnh hưởng trên những máy dùng Bash.

Cơ sở dữ liệu an ninh mạng NIST đánh giá lỗi Bash Bug ở cấp độ nguy hiểm 10/10. Khai thác thành công, tin tặc có thể chạm tay đến thông tin hệ thống, thay đổi hoặc gây tổn hại cho dịch vụ.
 

Các hệ thống dùng Ubuntu và phân hệ Debian khác dùng Dash không bị đe dọa bởi lỗi, nhưng các chuyên gia khuyến cáo vẫn nên kiểm tra shell.

Ngay sau khi lỗi được công bố, chuyên gia bảo mật Kenn White đã kiểm tra thử nghiệm cho thấy, hàng loạt website cấp chính phủ và quân đội (tên miền .mil và .gov) có thể bị chiếm dụng bởi lỗi. Ông thảng thốt trên Twitter về mức độ nguy hiểm của lỗi.

Giám đốc Liên minh An ninh Đám mây (CSA) Jim Reavis đánh giá lỗi Bash có mức độ nguy hiểm tương đương với lỗi Heartbleed trong OpenSSL công bố năm ngoái. 

Theo chuyên gia bảo mật Nguyễn Hồng Phúc, "lỗi này đang ở dạng nguy hiểm tiềm tàng, toàn bộ giới bảo mật đều nhận thấy sự nguy hiểm của lỗi, nhưng hiện chưa ai sáng tạo thành công một hướng tấn công hiệu quả".

"Lỗi nguy hiểm vì nó nằm trong một ứng dụng lõi (core application) mà hầu hết các hệ thống có dùng nhân Linux đa phần có chứa (bash). Hầu hết các chuyên gia đều thận trọng nhận định đây là một lỗi có khả năng khai thác. Trong bảo mật việc tìm ra lỗi và khai thác được lỗi là 2 mức độ riêng biệt".

Một số tài liệu thảo luận, chia sẻ về lỗi Bash từ các chuyên gia và cộng đồng an ninh mạng, bạn đọc quan tâm tham khảo từ: Akamai, lcamtuf blog, RedHat.

* Cập nhật: Ngày 25-9, một mã khai thác giả lập ở mức độ nghiên cứu đối với lỗi Bash đã được đăng tải trên GitHub.

Lỗi
Lỗi "Bash Shell" ảnh hưởng các hệ thống dùng Linux, họ Unix và cả Apple Mac OS X - Ảnh: TheHackerNews

Các phiên bản Bash 4.3 trở về trước, bao gồm cả bản vá phát hành vào ngày hôm nay vẫn bị ảnh hưởng bởi lỗi. Chưa có bản vá khắc phục hoàn toàn.

Các chuyên gia khuyến cáo cần kiểm tra shell và bất kỳ gói Bash nào đã cài đặt, vá lỗi nếu cần thiết. Để kiểm tra, gõ câu lệnh trong shell: 

env X="() { :;} ; echo busted" /bin/sh -c "echo completed"
env X="() { :;} ; echo busted" `which bash` -c "echo completed"

Nếu thấy từ "busted" đồng nghĩa hệ thống bị đe dọa bởi lỗi. Nếu không, Bash đã được khắc phục hoặc shell đang dùng trình thông dịch khác.

THANH TRỰC
Bình luận (0)
    Xem thêm bình luận
    Bình luận Xem thêm
    Bình luận (0)
    Xem thêm bình luận